WebinarJam Service Disruption

Incident Report for WebinarJam

Resolved

Service has been restored and are now fully operational. If you experience any additional difficulties, please contact support.
Posted Jun 10, 2026 - 14:24 UTC

Identified

Our Development team has identified the root cause and is working to implement a solution. We will return with updates as soon as we have more info.
Posted Jun 10, 2026 - 13:04 UTC

Investigating

We are currently experiencing a service disruption. Our Development team is working to identify the root cause and implement a solution. We will send an additional update as soon as we know more.
Posted Jun 10, 2026 - 12:35 UTC
This incident affected: APP (WebinarJam App, EverWebinar App).